MEPS - Operational information
Incident Report for CAB Group AB
Resolved
The problem has been fixed and you can now work in MEPS as usual again. We apologize for any inconvenience this may have caused you.

Please contact MEPS Support if you have any questions.

Kind regards

CAB
Posted Jan 29, 2024 - 11:07 CET
Investigating
There are problems with using MEPS at the moment. We are sorry for this and are working to solve the problem as soon as possible.

The error affects users in all markets.
We will keep you updated.

Kind regards

CAB
Posted Jan 29, 2024 - 10:52 CET
This incident affected: MEPS (MEPS Web Application, MEPS Inspection App).