MEPS - Operational information

Incident Report for CAB Group AB

Postmortem

Regarding incident on January 8

During the period January 8, 2026, from 12:00 to 14:40 CET, you were able to see assignments in the Current Status view that did not belong to your organization. The customers whose assignments were displayed in the list will be contacted by CAB Group AB.

Regards,

CAB Group AB

Posted Jan 09, 2026 - 12:49 CET

Resolved

The problem has been fixed and you can now work in MEPS as usual again. We apologize for any inconvenience this may have caused you.

Please contact MEPS Support if you have any questions.

Kind regards

CAB
Posted Jan 08, 2026 - 17:35 CET

Investigating

There is an issue with using MEPS and the "follow-up view" at the moment. We apologize for this and are working to solve the problem as soon as possible.

We will keep you updated.

Kind regards

CAB
Posted Jan 08, 2026 - 14:42 CET
This incident affected: MEPS (MEPS Web Application, MEPS Inspection App).