CAB Repair - Operational information
Incident Report for CAB Group AB
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 08:22 CET
Investigating
CAB Repair failure

Currently we have a failure in CAB Repair. We apologize for the inconvenience that this may cause and are working to resolve this as soon as possible.

The failure affects all markets

We will update this incident continuously.

Kind regards
CAB
Posted Mar 26, 2024 - 07:43 CET
This incident affected: CAB Plan (CAB Plan - All markets, Damage Inspection Booking Web Application (DIB), CAB Plan Repair, KPI & Reporting service).