MEPS - Operational information
Incident Report for CAB Group AB
Resolved
The problem has been fixed and you can now work in MEPS as usual again. We apologize for any inconvenience this may have caused you.

Please contact MEPS Support if you have any questions.

Kind regards

CAB
Posted Jun 28, 2024 - 08:25 CEST
Investigating
There are issues with using MEPS at the moment. This concerns main contractors that invites subcontractor.

Currently, the invitation modal is not appearing automatically as it should when you attempt to invite a subcontractor.
As a temporary workaround, please reload the page, after which the invitation modal should appear and allow you to proceed with your invitation.

We are actively working on resolving this issue and will deploy a fix tonight at 21:00. We apologize for any inconvenience this may cause you.

The problem affects users in all markets.

Kind regards

CAB
Posted Jun 27, 2024 - 09:59 CEST
This incident affected: MEPS (MEPS Web Application, MEPS Inspection App).